Problème d'airbag : sensor, side airbag fault

Vous avez un doute sur le type de sujet ? Postez donc ici.

Re: Problème d'airbag : sensor, side airbag fault

Messagede lazare59 » Mar 11 Juin 2019, 19:01

Là c'est pire : rien que le fait de changer la batterie suffit à avoir le voyant allumé ! :P
N'essayez jamais de convaincre une femme... Il suffit d'attendre qu'elle change d'avis ! :innocent:

Clubman Cooper S BRG (2008) / 650i E63 Tiefseeblau (2008) / Z3 Coupé 2.8 ArktisSilber (1999) / 628 csi Achatgruen (1985) / 1602 Sahara (1975)
Avatar de l’utilisateur
lazare59
Zecrétaire
Zecrétaire
 
Messages: 18837
Inscription: 26 Avr 2013
Localisation: Villeneuve d'Ascq
Département: 59 Nord
Véhicule: Z3 Coupé 2.8i

Re: Problème d'airbag : sensor, side airbag fault

Messagede cardoz » Mar 11 Juin 2019, 19:19

8O c'est pas bien de mentir :evil: !! il faut juste remettre l'horloge à l'heure :happy: . Enfin je parle du E85 .... pour le E89 c'est une autre histoire :evil: ! :D ;-)
Z3 1.9 /2.2/2.8 Mazda mx5
Z4 2.5 individual Maritime
Avatar de l’utilisateur
cardoz
CotiZant
CotiZant
 
Messages: 7091
Inscription: 26 Aoû 2008
Localisation: Vieux Lille
Département: 59 Nord
Véhicule: Z4 Roadster 2.5i 192ch

Re: Problème d'airbag : sensor, side airbag fault

Messagede JuleZ » Dim 15 Sep 2019, 22:02

Salut les Zistes, ça faisait un bail! :whistling:

Titine se porte toujours bien à 330 000km, mais le voyant d'airbag allumé, ça ne passe plus au CT :huh:

J'avais, quand il était apparu, lu le défaut avec INPA, c'était ce satané capteur de présence dans le siège passager.
Me décidant à m'y atteler, je relis les défauts du module airbag : mince alors, li y en a de nouveaux capteur de choc latéral conducteur :oops:
Un tour sur le net, je tombe sur ce thread... qui ne me convainc pas vraiment (pas réussi à trouver le bon capteur sur ebay et autres sources) et continue à fouiner.

La solution gratuite existe, mais est un peu triste : perte de la fonctionalité du(des) airbag(s) concerné(s) ;-)

Dans la suite logicielle BMW dont INPA fait partie, existe NCSExpert qui permet de coder les ECU de nos véhicules.
Je sais, annoncé à froid, comme ça, ça peut faire un peu peur. :online:

Mais :
Un freeware édité par un collège de collègues (BMistes) américains (et autres), NCSDummy, permet de traduire les infos contenues dans les différents ECU (héxadécimal/binaire, suite de caractères/chiffres à priori incompréhensibles), en texte ordonné (en Deutsch/english).
On a alors accès à la compréhension de la configuration codée dans l'ECU concerné.
Ce logiciel (NCSDummy) permet de préparer de façon safe la modification de cette configuration.
NCSExpert sert à downloader/uploader une configuration dans l'ECU.

Pour résumer :
Accès au contenu de l'ECU via NCSExpert -> récolte d'un fichier A
Ouverture du dit fichier A avec NCSDummy -> accès à la config de l'ECU
Modification de la config & création d'un nouveau fichier B (toujours avec NCSDummy)
Ecriture du dit fichier B dans l'ECU via NCSExpert

En l'occurrence, j'ai supprimé les fonctions airbag latéral passager & conducteur, ainsi que les deux capteurs de choc latéral.
On efface les défauts avec INPA, WOOHOO! le voyant s'éteint, la mémoire défaut de l'ECU reste vierge. :thumbsup:
Coupe le contacte, le remets...le voyant s'allume, s'éteint un dixième de seconde et se rallume :dur:

Eh oui, l'ECU est bête et c.., on lui dit que la config véhicule ne dispose ni d'airbags latéraux, ni de capteurs de choc latéraux, et pourtant il détecte des choses branchées à son connecteur.. et suspecte du coup un problème :innocent:

Résolution simple : accès physique à l'ECU (par la joue coté conducteur de la console centrale (deux vis)), débrancher le connecteur, désassembler ce dernier pour accéder aux pins, sortir les pins 16 à 21 (16,17 & 18,19 pour les airbags, 20,21 pour les signaux des capteurs), les isoler une à une (ou couper si pas de regret) afin que l'ECU ne voit plus de composant connectés où il ne devrait plus y en avoir. (et que les airbags ne voient pas malencontreusement un potentiel à leurs bornes si on laisse les pins se balader... :evil:
(ceci dit, il faut du jus pour les faire péter, les 2 bornes de chaque airbag sont shuntées (fils fusibles) à trois endroits sur le circuit entre l'ECU et l'airbag lui même, afin d'éviter justement que ces derniers ne pêtent à des moments innoportuns.)
Re-efface les défauts avec INPA et c'est fini ! :clap:

sources et infos pour les anglophones :
sources soft et tuto install : http://www.bimmerforums.com/forum/showthread.php?2184573-The-Z3-Diagnostics-Thread-Instructions-Experiences-Discussions-Experimentation
Sources NCSDummy, tuto et fonctionnement global : https://www.bimmerforums.com/forum/showthread.php?1553779-NCS-Dummy-Taking-the-expert-out-of-NCS-Expert&highlight=ncs+code+airbag

:!: En creusant un tout petit peu, on peut se rendre compte que cela ouvre bon nombre de possibilités... :whistling: :!:
(prochaine étape : calibration de la centrale inertielle de l'ESP pour ne plus le déclencher sur les ralentisseurs... et qui sait peut être trouver une/des carto des paramètres ESP pour qu'il intervienne un peu plus tard, ça éviterait de le désactiver après chaque démarrage :P )

A+
Z3 Coupé 3.0 Topasblau
Avatar de l’utilisateur
JuleZ
habitué
habitué
 
Messages: 536
Inscription: 09 Aoû 2008
Localisation: Compiègne
Véhicule: Z3 Coupé 3.0i

Re: Problème d'airbag : sensor, side airbag fault

Messagede Zillou57 » Dim 15 Sep 2019, 22:38

Hé bé P..... suis pas sorti de l'auberge. ;-)

Je t'invite à passer un we en Lorraine pour régler mon problème l'ami.......Je ne vois pas d'autre solution..... :D
Qu'importe l'ivresse, pourvu qu'on ait le flacon.
Son Z3 - Mon Z4
Avatar de l’utilisateur
Zillou57
CotiZant
CotiZant
 
Messages: 478
Inscription: 27 Sep 2016
Localisation: Le Saulnois en Moselle
Département: 57 Moselle
Véhicule: Z4 sDrive 35is

Re: Problème d'airbag : sensor, side airbag fault

Messagede La Globule » Lun 16 Sep 2019, 07:48

lazare59 a écrit:
Zillou57 a écrit:Juju pas vu de led quand j ai démonté le compteur pour refaire le cuir du rdv. Juste des ampoules...


Enlève l'ampoule et tu verras, ça restera faiblement allumé. ;-)

Non Julien, il n'y a aucune "LED" en plus de l'ampoule :dur:
Si tu enlèves l'ampoule il faut obturer le trou sinon la lumière passe par le trou et tu as l'impression que c'est légèrement allumé :thumbup:
Z3 3.0l roadster griZe - Z3 ///M roadster noir - Z3 3.0l coupé pistache
Ma pistache file comme un pet dans un courant d'air
Avatar de l’utilisateur
La Globule
CotiZant
CotiZant
 
Messages: 15161
Inscription: 07 Mai 2010
Localisation: Ch'ti de Seine et Marne
Département: 77 Seine-et-Marne
Véhicule: Z3 Coupé 3.0i

Re: Problème d'airbag : sensor, side airbag fault

Messagede lazare59 » Lun 16 Sep 2019, 08:05

T'inquiète pas, c’est ce que j'avais fait. :P

Mais c’est bien considéré comme allumé au CT du coup...
N'essayez jamais de convaincre une femme... Il suffit d'attendre qu'elle change d'avis ! :innocent:

Clubman Cooper S BRG (2008) / 650i E63 Tiefseeblau (2008) / Z3 Coupé 2.8 ArktisSilber (1999) / 628 csi Achatgruen (1985) / 1602 Sahara (1975)
Avatar de l’utilisateur
lazare59
Zecrétaire
Zecrétaire
 
Messages: 18837
Inscription: 26 Avr 2013
Localisation: Villeneuve d'Ascq
Département: 59 Nord
Véhicule: Z3 Coupé 2.8i

Re: Problème d'airbag : sensor, side airbag fault

Messagede La Globule » Lun 16 Sep 2019, 08:28

C'est une interprétation mais pas une réalité ;-)
Z3 3.0l roadster griZe - Z3 ///M roadster noir - Z3 3.0l coupé pistache
Ma pistache file comme un pet dans un courant d'air
Avatar de l’utilisateur
La Globule
CotiZant
CotiZant
 
Messages: 15161
Inscription: 07 Mai 2010
Localisation: Ch'ti de Seine et Marne
Département: 77 Seine-et-Marne
Véhicule: Z3 Coupé 3.0i

Re: Problème d'airbag : sensor, side airbag fault

Messagede lazare59 » Lun 16 Sep 2019, 08:44

En effet mais pour toi c'est une réalité quand tu es recalé ! :roll:
N'essayez jamais de convaincre une femme... Il suffit d'attendre qu'elle change d'avis ! :innocent:

Clubman Cooper S BRG (2008) / 650i E63 Tiefseeblau (2008) / Z3 Coupé 2.8 ArktisSilber (1999) / 628 csi Achatgruen (1985) / 1602 Sahara (1975)
Avatar de l’utilisateur
lazare59
Zecrétaire
Zecrétaire
 
Messages: 18837
Inscription: 26 Avr 2013
Localisation: Villeneuve d'Ascq
Département: 59 Nord
Véhicule: Z3 Coupé 2.8i

Re: Problème d'airbag : sensor, side airbag fault

Messagede cardoz » Lun 16 Sep 2019, 12:11

Pas tout bien compris :dur: mais bravo JuleZ :clap: !! ( j'me dis que j'ai eu du bol avec mon Z de 99 .. mais j'ai eu le chassis :( )
Z3 1.9 /2.2/2.8 Mazda mx5
Z4 2.5 individual Maritime
Avatar de l’utilisateur
cardoz
CotiZant
CotiZant
 
Messages: 7091
Inscription: 26 Aoû 2008
Localisation: Vieux Lille
Département: 59 Nord
Véhicule: Z4 Roadster 2.5i 192ch

Re: Problème d'airbag : sensor, side airbag fault

Messagede JuleZ » Lun 16 Sep 2019, 19:40

Image

Peut être est-ce plus parlant/motivant avec une image...
La modif de config se réduit à cocher des cases... et faire gaffe à sa gestion de fichiers : conserver le fichier lu dans l'ECU sans l'altérer pour pouvoir retourner à l'état usine, créer une copie que l'on modifiera dans NCSDummy ce sera ce fichier que l'on charge dans l'ECU.

En l'occurrence, j'ai décoché Right Side Airbag 1, Right Side Airbag 2, Left Side Airbag 1, Left Side Airbag 2, ainsi que Satellite 1 et Satellite 2 (capteurs latéraux)

Image
Le pourquoi des satellites est visible entre l'image précédente et celle-ci:
Image

En cliquant chaque ligne, la partie du milieu décrit le code impliqué :
Si satellite est aktiv, la ligne 'Options' (dans la partie milieu) contient SEITENAIRBAG
Si satellite est nicht_aktiv, la ligne 'Options' contient !SEITENAIRBAG
'!' signifie 'non', 'sans' en code dans certains langages. Donc, satellite est aktiv si présence de seitenairbag, nicht_aktiv si pas de seitenairbag.
Simple, non? :P

La lecture via INPA après config donne :
Image

J'avoue que deux fois l'erreur 22, il a un peu abusé....il aurait du voir le MRSA vorne rechts, et donc ça nous renseigne sur le fait que l'ECU teste l'ensemble de ses entrées/sorties à chaque dmarrage et que si sa config lui dit qu'il n'a pas de side airbag, s'il détecte quelque chose branché à cet endroit, il déclare un défaut. D'où la suppression de certains contacts sur le connecteur ECU. (plus simple à mon sens que de démonter les sièges et garnitures de portes pour débrancher 4 composants)

Et cela laisse le temps à ceux qui le souhaite de résoudre le problème (changer le capteur) entre deux contrôles techniques...

Le plus gros problème est que le lexique entre INPA et NCS n'est pas identique, mais avec un poil de google-fu, ça passe :happy:
C'est un poil intimidant mais pas sorcier :coffee:

S'il y a de l'intérêt/demande, je pourrais ptêt faire un vrai tuto, mais un coup de google traduction sur les deux liens donnés précédemment sont plus que suffisants ;-)
Dernière édition par JuleZ le Lun 16 Sep 2019, 19:48, édité 1 fois.
Z3 Coupé 3.0 Topasblau
Avatar de l’utilisateur
JuleZ
habitué
habitué
 
Messages: 536
Inscription: 09 Aoû 2008
Localisation: Compiègne
Véhicule: Z3 Coupé 3.0i

Re: Problème d'airbag : sensor, side airbag fault

Messagede cardoz » Lun 16 Sep 2019, 19:46

ha !! facile en fait ! :lol: :lol: !! :arrow: :arrow: :? !
Z3 1.9 /2.2/2.8 Mazda mx5
Z4 2.5 individual Maritime
Avatar de l’utilisateur
cardoz
CotiZant
CotiZant
 
Messages: 7091
Inscription: 26 Aoû 2008
Localisation: Vieux Lille
Département: 59 Nord
Véhicule: Z4 Roadster 2.5i 192ch

Re: Problème d'airbag : sensor, side airbag fault

Messagede JuleZ » Lun 16 Sep 2019, 19:48

Très sincèrement, bien plus qu'il n'y paraît. ;-)
Z3 Coupé 3.0 Topasblau
Avatar de l’utilisateur
JuleZ
habitué
habitué
 
Messages: 536
Inscription: 09 Aoû 2008
Localisation: Compiègne
Véhicule: Z3 Coupé 3.0i

Re: Problème d'airbag : sensor, side airbag fault

Messagede cardoz » Lun 16 Sep 2019, 19:54

oui , surement , les explications en informatique sont tjs déprimantes :dur: :D !
Z3 1.9 /2.2/2.8 Mazda mx5
Z4 2.5 individual Maritime
Avatar de l’utilisateur
cardoz
CotiZant
CotiZant
 
Messages: 7091
Inscription: 26 Aoû 2008
Localisation: Vieux Lille
Département: 59 Nord
Véhicule: Z4 Roadster 2.5i 192ch

Précédente

Retourner vers Divers Technique Z3

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité